1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Hi Guest, welcome to the TES Community!

    Connect with like-minded professionals and have your say on the issues that matter to you.

    Don't forget to look at the how to guide.

    Dismiss Notice
  3. The Teacher Q&A will be closing soon.

    If you have any information that you would like to keep or refer to in the future please can you copy and paste the information to a format suitable for you to save or take screen shots of the questions and responses you are interested in.

    Don’t forget you can still use the rest of the forums on theTes Community to post questions and get the advice, help and support you require from your peers for all your teaching needs.

    Dismiss Notice

Can't acces the TES forums using Mozilla. Anyone else having this problem.

Discussion in 'Teaching overseas' started by yasimum, Apr 29, 2011.

  1. yasimum

    yasimum New commenter

    I cannot use the community section of TES with Mozilla Firefox. Never had this problem before and it works with Explorer (but I hate explorer!) What to do?
     
  2. rednelly84

    rednelly84 New commenter

    Try updating your browser to the latest version. I was having problems too with this and other sites...the update solved the problem.
    :)
     
  3. yasimum

    yasimum New commenter

    Will try this as FB is mucking up too. Cheers.
     
  4. yasimum

    yasimum New commenter

    Thanks rednelly, it worked!

     
  5. Interesting. I updated to FF4 and found the peformance so bad that I went back to the previous version. Of course, reinstalling that has messed up all of my add-ons, which worked prefectly well before I upgraded......
     

Share This Page